Robofun 機器人論壇

 找回密碼
 申請會員
搜索
熱搜: 活動 交友 discuz
查看: 3413|回復: 10

開發板管理員版本更新

[複製鏈接]
發表於 2019-6-13 08:46:28 | 顯示全部樓層 |閱讀模式
各位好

我最近入手一塊arduino uno wifi rev2板子
而我目前的Arduino程式版本為1.8.9,由於在開發板裡面找不到arduino uno wifi rev2板子
透過網路找資料是說開發板管理員(Arduino AVR Boards)版本需為1.6.24版本以上
我目前是1.6.23,想利用程式自動更新一直失敗,請問有什麼方法可以手動更新嗎?

圖片1.png

點評

海!外直播 cutt.us/77c 禁闻视频 v.ht/6hhh 好多年前,我在上海本地某论坛混的时候,去过那个网站,整整一层楼面办公的都是管理员,专门删贴的。网络是智力密集型行业,在中国却是劳动力密集型的。   發表於 2021-9-9 09:29
發表於 2019-6-13 12:01:03 | 顯示全部樓層
基本上, IDE最新版就是 1.6.23,
如果要用 1.6.24, 我可以用 WEB 版本或 Hourly版本
不過我覺得沒必要, 舊的版本即可
至於要解決下載問題
可以試看看
功能表 - 檔案 - 徧好設定
2.jpg
找出 preferences.txt 所在目錄
注意!!!!!!!!!!!!每個人的目錄不同
我的是 C:\Users\User\AppData\Local\Arduino15

把裡面的 package_index.json.tmp  重新命名
重開一次軟體看看
 樓主| 發表於 2019-6-14 08:30:59 | 顯示全部樓層
本帖最後由 Gullit 於 2019-6-14 08:36 編輯
超新手 發表於 2019-6-13 12:01
基本上, IDE最新版就是 1.6.23,
如果要用 1.6.24, 我猜可以用 WEB 版本或 Hourly版本
不過我覺得沒必要,  ...


感謝回覆

我有下載過Hourly版本,還是無法更新到1.6.24

另外您說要把『把裡面的 package_index.json.tmp重新命名』
請問是什麼意思?

把檔案名稱改掉嗎? 讓程式以為沒有『package_index.json.tmp』這個檔案嗎? 因此再重新下載一次嗎?
我剛剛試過了,還是無效

我有直接進入https://downloads.arduino.cc/packages/package_index.json這個網址
有看到下列這段程式碼,也下載了"megaavr-1.6.24.tar.bz2"這個檔案
解壓縮後為『megaavr-1.6.24.tar』,請問可以放到哪個資料夾???

        {
          "name": "Arduino megaAVR Boards",
          "architecture": "megaavr",
          "version": "1.6.24",
          "category": "Arduino",
          "help": {
            "online": "http://www.arduino.cc/en/Reference/HomePage"
          },
          "url": "http://downloads.arduino.cc/cores/megaavr-1.6.24.tar.bz2",
          "archiveFileName": "megaavr-1.6.24.tar.bz2",
          "checksum": "SHA-256:0910af1d6eb44b65fee77c81a7a83ee420e6a7c1622f90754e91a5127d317a1d",
          "size": "709516",
          "boards": [
            {
              "name": "Arduino Uno WiFi Rev2"
            }
          ],
          "toolsDependencies": [
            {
              "packager": "arduino",
              "name": "avr-gcc",
              "version": "5.4.0-atmel3.6.1-arduino2"
            },
            {
              "packager": "arduino",
              "name": "avrdude",
              "version": "6.3.0-arduino14"
            },
            {
              "packager": "arduino",
              "name": "arduinoOTA",
              "version": "1.2.1"
            }
          ]
        },
發表於 2019-6-14 09:00:11 | 顯示全部樓層
WEB 版本上面有
未命名.jpg
發表於 2019-6-14 09:23:18 | 顯示全部樓層
解壓縮後, 放在
C:\Users\User\AppData\Local\Arduino15\packages\arduino\hardware\megaavr\1.6.24
注意!!!!!!!!!!!!!!!
紅色部份是我的目錄
你的目錄則要參考你自己的徧好設定
藍色部份的目錄你應該沒有, 要自己建
結果應該看起來像
3.jpg
發表於 2019-6-14 10:01:26 | 顯示全部樓層
本帖最後由 超新手 於 2019-6-14 10:30 編輯
我有下載過Hourly版本,還是無法更新到1.6.24

我不知道你是聴誰說1.6.24 的事?
但根據我自己的 IDE 版本
Arduino AVR boards 最新版本只到 1.6.23
而且要更新的是  Arduino megaAVR boards , 版本到 1.8.1
而不是 Arduino AVR boards
未命名.jpg
 樓主| 發表於 2019-6-14 11:20:29 | 顯示全部樓層
我的Arduino的目錄只到C:\Users\user\AppData\Local\Arduino15
主程式我是從官網上抓的,怎麼會這樣??
圖片2.png
發表於 2019-6-14 12:15:28 | 顯示全部樓層
沒有那部份, 表示你沒有灌 M0 系列的 Arduino
看來...你還是乖乖解決下載問題可能比較快一點
如果偏好設定改成沒有代理伺服器
可以解決下載問題嗎?
未命名.jpg

 樓主| 發表於 2019-6-14 13:08:51 | 顯示全部樓層
還是失敗,情況跟第一樓一樣....
如果你說1.6.23是最新版,那系統應該也不會自動更新到1.6.24
我一開始的資訊是看下面網址,有提到『安装或更新“Arduino megaAVR电路板”包。需要1.6.24或更高版本。』
https://www.yiboard.com/thread-1030-1-1.html

你說的 M0 系列的 Arduino是什麼版本?  網路上可以下載嗎?
感覺我照你前面的方式做,放到對的目錄下,應該就有這個板子資訊了
 樓主| 發表於 2019-6-14 13:11:39 | 顯示全部樓層
Gullit 發表於 2019-6-14 13:08
還是失敗,情況跟第一樓一樣....
如果你說1.6.23是最新版,那系統應該也不會自動更新到1.6.24
我一開始的資 ...

當初感覺買第一代的arduino uno wifi 就沒這個問題了   
您需要登錄後才可以回帖 登錄 | 申請會員

本版積分規則

小黑屋|手機版|Archiver|機器人論壇 from 2005.07

GMT+8, 2021-10-27 10:52 , Processed in 0.206276 second(s), 9 queries , Apc On.

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回復 返回頂部 返回列表