Robofun 機器人論壇

 找回密碼
 申請會員
搜索
熱搜: 活動 交友 discuz
查看: 11847|回復: 43

[求救]電流超過 10A ?(確定是電壓太低發生OS不穩,已經解決~)

[複製鏈接]
發表於 2010-3-1 15:35:35 | 顯示全部樓層 |閱讀模式
本帖最後由 tommylin 於 2010-7-8 23:34 編輯

Hi 大大們~
我再 Roboard 上接了 16 顆 Hitec 8498 Servo
全部一起動作時... 瞬間關機..

後來發現是電源供應器輸出電流太小...
請問我可以朝哪個方向處理呢?
謝謝~
發表於 2010-3-1 15:58:57 | 顯示全部樓層
你是供多少電呀!18 顆一起動 不會有問題呀
發表於 2010-3-1 15:59:19 | 顯示全部樓層
出力太小喔
買顆大一點的電源啊
我有5V / 20A的電源喔 (都是你..害我又廣告了)
或是你可以"很多組" 6V 的電池"並聯"  
但得注意別用鋰電, 多組並聯很容易爆炸...我上個月才炸掉一組
鋰電因為活性強... 電壓只要稍有差異, 電流又強的情形下很容易出事
建議這可以用鎳氫電池組會比較安全 , 且模型店很容易買到喔
發表於 2010-3-1 16:03:36 | 顯示全部樓層
或是另外使用SERVO控制板
像我有自己做32軸的版本
分兩組各16個SERVO供電, 這樣也比較不會掛掉
大型的電源消耗並不適合直接使用roboard實做喔, 燒掉你就事情大條了
之前我才有個客戶弄到溫度過高爆掉Roboard上面接的VGA卡
當時的電流估計約是搞到17A左右 , 天曉得他到底是怎麼接的@@
 樓主| 發表於 2010-3-1 16:46:36 | 顯示全部樓層
本帖最後由 tommylin 於 2010-3-1 16:47 編輯

我是輸入 6V,
本來電源供應器限制輸出在 5A,
之前都只有接上一個 Servo 都正常...
昨天把 18顆全部裝上...
但是只要一執行 REPLAYS 的命令... ( 全部 Servo 動作, 播放 Frames ..)
系統就自動重新開機...
我把輸出電流調到最大 10A ... 可以看到電源供應器顯示瞬間輸出 10A,
Servo 動了一點點角度以後..
系統就重新開機了...
 樓主| 發表於 2010-3-1 16:52:06 | 顯示全部樓層
本帖最後由 tommylin 於 2010-3-1 16:54 編輯

我的電源是 AC 110V to DC 0~12V
還沒有測試過用電池...
我想問一下...
1. Kondo 走路的時候, 消耗總電流多少?
2. RB-100 建議輸出電流 Max 多少?
3. 真的需要像 鯨魚大說的~ 要外接電源嗎...
這樣機器人變重也變肥了 = = 哈哈~
謝謝~
發表於 2010-3-1 18:37:43 | 顯示全部樓層
我哪有說外接電源, 這是你自己講的哩, 機器人真的在用也不可能外接電源啊
牽一條線在那邊走很好笑哩
我是說可能多幾組電池並聯
不然就是單一組鋰電, 反正鋰電本來就可以高電流放電

說實話我沒試過這麼多顆一起接roboard , 也不曉得他有這種極限
通常我都是透過另外的servo控制板去控制SERVO, 控制板沒這個問題
roboard主要被我拿來做影像處理的部分
這部分可能得要請安東尼老大來解惑了
看來應是瞬間大電流導致roboard電源不穩而重開
發表於 2010-3-1 18:50:57 | 顯示全部樓層
我的電源是 AC 110V to DC 0~12V
還沒有測試過用電池...
我想問一下...
1. Kondo 走路的時候, 消耗總電 ...
tommylin 發表於 2010-3-1 16:52


1. Kondo 走路時到底用多少 我沒有實際量過! 但我是用 12v 4a 的變壓器來接
2. 輸出電流 建議是 10A 超過的沒有試過

你是用變壓器 還是用電源供應器 呀!
 樓主| 發表於 2010-3-1 19:17:48 | 顯示全部樓層
本帖最後由 tommylin 於 2010-3-1 19:24 編輯

我用的是..."電源供應器"
等一下貼照片, 影片上來..麻煩大家幫我查原因..

我說的"外接電源" 是指~
RB-100 和 Servo 的電源分開..
像 Arduino 一樣,
主控制板 和 Servo 的電源分離..
抱歉~ 我沒說明清楚...
發表於 2010-3-1 20:09:40 | 顯示全部樓層
其實~~用電池就沒問題了~~
因為你開電時,會有瞬間電流~~供應器是用RC充放電,
所以瞬間電流都被吸光了~~就會來不及充滿,我以前就有
遇過~~~供應器不能這樣用~~尤其是大電流~~
發表於 2010-3-1 20:24:37 | 顯示全部樓層
啊....所以是電容的問題喔, 又增廣見聞了
所以即使我用可以供應20A的電源供應器也是會掛掉喔??

這個問題不曉得使用DC converter可不可以解決
不過這樣應該就沒問題了吧
因為應該是沒人會拿電源供應器來控制機器人才對
發表於 2010-3-1 21:07:47 | 顯示全部樓層
一般變壓器( < 6A )玩 KONDO 可能不太穩, 如果你要同使驅動17 顆馬達的話.
我是用一顆 11.1V 25C 1300mAh 的鋰聚玩 KONDO.
有想過並聯兩顆鋰聚, 可以玩久一點, 但剛看到鯨大說很危險, 就不想試了 XD
發表於 2010-3-1 21:27:14 | 顯示全部樓層
其實不會,你要去買5CELL的6V專用電池,就不會有問題,
我的六足玩到現在,沒有問題過~~~

DC converter一定可以,只是你要把它搞"大"一點,我也
沒意見~~
發表於 2010-3-1 21:56:57 | 顯示全部樓層
鋰聚會危險主要是因為兩顆電壓不同(我用到爆炸就是這樣)
會因為鋰電本身活性比較高, 會有從一顆充電到另外一顆導致電流過大過熱的問題而爆炸
如果你買兩顆一樣的, 並且兩顆從頭到尾都並聯就應該不會有問題
且得要確實遵守充放電規矩, 不要過充過放
這可是我玩到爆炸以後到處找資料的心得啊

不然你可以考慮買大顆的鋰聚, 有賣那種4000mAH的, 保證玩到爽了
但用大顆又會變重...
其實要玩久一點建議插電線, 用變壓器

DC converter 可以有任何對應規格
只是... 很貴就是, 動不動就是幾千的, 直接用充電電池比較省錢哩
發表於 2010-3-1 22:04:23 | 顯示全部樓層
本帖最後由 rayrider 於 2010-3-1 22:06 編輯

用五顆鎳氫電池保證ok,最好並連個電容6600uf以上。
 樓主| 發表於 2010-3-1 22:40:38 | 顯示全部樓層
Hi ALL,
先感謝大家幫忙分析和建議..
先報告測試進度...

我現在使用 鎳氫電池 AA, 2450mAh,  6 CELL ( 1.2 V x 6 = 7.2 V )
還是一樣自動重新開機..
目前還沒有結論, 確定問題的癥結~
我會繼續測試..
發表於 2010-3-1 22:59:03 | 顯示全部樓層
那你慢慢增加一個servo,測試
或是你有電流計,算一下,是不是真的過電流導致重開機的。
發表於 2010-3-1 23:45:18 | 顯示全部樓層
所謂的分開供電得要
1. 電池出來的地 , 分別接到"所有SERVO的地"和板子的地
2. 電池的VCC, 分別接到"所有SERVO的VCC"和板子的VCC (最好是使用兩組電池)
3. Servo的S接到板子...

不過看來似乎還是有大電流衝突到roboard
是否把接線的方式或是照片分享來看看是怎麼回事呢?
 樓主| 發表於 2010-3-2 00:29:35 | 顯示全部樓層
本帖最後由 tommylin 於 2010-3-2 00:31 編輯

等等喔~ 最大電流約 6.2A
影片如下:

看來自動重新開機有可能是 "程式 Bug",
因為影片中沒有發生..
我需要在查一下, 確認一下...
會盡快回報結果給大家..
發表於 2010-3-2 20:46:56 | 顯示全部樓層
哈哈^^
這什麼東西啊
看起來是一台跌倒的傢伙在那邊掙扎
要讓他站起來!!! 承重不同的情況下, 耗電是不一樣的哩
您需要登錄後才可以回帖 登錄 | 申請會員

本版積分規則

小黑屋|手機版|Archiver|機器人論壇 from 2005.07

GMT+8, 2022-8-12 16:14 , Processed in 0.257676 second(s), 7 queries , Apc On.

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回復 返回頂部 返回列表